AnsweredAssumed Answered

FRDM-K64 I2C accelerometer KSDK v1

Question asked by dave_c on Dec 8, 2017
Latest reply on Dec 8, 2017 by Mark Butcher

Hi everyone,

 

I have to make a project using uC/OS III as rtos on the FRDM-K64F.

 

I am trying to read the values of the accelerometer (FXOS87000CQ) inside the board using, as base, the project provided by micrium with uC/OS III (that uses the old ksdk 1.0).

 

I found this example on the nxp community and so I tried to follow it changing the port of I2C (the accelerometer is connected to PTE24 - SCL and PTE25 - SDA in mux mode 5) and the I2C module that is I2C0. 

FXOS8700CQ - Bare metal example project 

 

Using a scope I see something happens on the port, but when I read the values of the accelerometer I have always 0xFF as result but because I am not very skilled with the protocol and the board I cannot find the problem(s).

 

I tried also disabling the magnetometer and using only the accelerometer but I obtain the same results. Using the project example generated by the sdk builder, it works. (but it use KSDk v2.3) 

 

Can someone help me explain why the code is not working?

Are there other examples using KSDK 1.0 and the K64F?

Is there a way to update or create a new project using the new KSDK and the uC/OS III rtos? 

 

Any help on this would be appreciated.

Thanks a lot.

Davide

Outcomes