AnsweredAssumed Answered

Cannot get MIMXRT1050 board loaded with SDK gpio LED driver demo via MCUXpresso IDE 10.1.0 589

Question asked by Ed Waldner on Dec 8, 2017
Latest reply on Dec 18, 2017 by Ed Waldner

Hello MCUXpresso IDE team and NXP community using the RT1050 processor on MCUXpresso IDE.

 

This question is an extension to the thread below:

MCUXpresso and RT1050 HyperFlash Programming 

 

At this point I am looking to establish a debug session running for any demo/trial project on the MIMXRT1050-EVK.

 

LPCX support replied in the above thread pointing to the following document:

Overview of using the MIMXRT1050-EVK(B) with MCUXpresso IDE 

 

I checked my test board to match points 1 - 8 in the overview section. My eval board is powered thru the OpenSDA port. The LED next to J1 is lit green and the status LEDs on the RJ45 port are lit green and amber. SW7 is set to boot from hyperflash. I am not using external power.

 

Yesterday I had one EVK board (schematic rev A3) that had to have its OpenSDA firmware updated from v241 to 244. Today, I tried another EVK board (schematic rev A4) that came preloaded with OpenSDA firmware v244. 

 

I am running MCUXpresso IDE v10.1.0 build 589 on a Dell Latitude 5580 laptop running Windows 10 Enterprise 1703 (build 15063.726). I have also loaded SDK v2.3.0 for the EVK-MIMXRT1050 (manifest version 3.2.0). 

 

So far I tried to import SDK demo projects hello_world and hello_world_xip and attempted to start a debug session on these boards. Having read thru the Overview document (link above) posted yesterday, I realized that the projects in the SDK are configured to link to RAM. The recommendation from this doc was to try a simple driver demo from the SDK such as the GPIO LED output demo.

 

For all of these demos, on both board types I am running into the following problem:

1. selected project builds error free

2. debug session crashes while transferring to eval board with the following dialogs

 

connection failed - Ee(FF). Redlink interface error 255... Retrying
Failed on connect: Ee(FF). Redlink interface error 255.
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Last stub error 0: OK
Last sticky error: 0x0 AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
(100) Target Connection Failed
error closing down debug session - Ee(FF). Redlink interface error 255.

 

I also attached two dialogs that pop up along with the above console output.

 

At this point it seems that two boards operate the same way with my MCUXpresso IDE installed base. The failure is consistent among SDK demo projects. I also tried to create a new project using the 1052 as the base part (as per the Project Creation: section in the RT1050_BriefOverview_v101.pdf doc linked above) and ran into the same connection failure with the same failure console output and dialogs. 

 

I am guessing that I have some configuration error. I tried these boards on a colleague's MCUXpresso IDE install and he had similar connection issues. 

 

Repeated connect/reconnect of USB cable to OpenSDA port did not work.

Restarted MCUXpresso IDE several times, no dice.

 

Does anyone have any ideas on how to overcome this connection issue? 

Attachments

Outcomes