AnsweredAssumed Answered

Processor Expert sets wrong clock mode for K02FN64

Question asked by SCOTT MILLER on Nov 25, 2017
Latest reply on Nov 27, 2017 by Alice_Yang

I'm using PEx with KSDK 1.3 on one project (yeah, I know, I'm working on moving off of it) and I discovered that it's not setting the MCG BLPE mode correctly.  If you choose BLPE in a clock configuration, it comes out as kMcgModePBE - which doesn't exist on this part.  The result is that when you try to switch to it, it looks up the appropriate transition from its matrix and gets the wrong answer, so it's perpetually stuck transitioning to FEI mode.

 

Here's a screenshot:

 

Wrong clock mode

My fix for now is to disable the 'read only' option for the structure that it generates and override the setting myself:

 

clkLowPower.mcgConfig.mcg_mode = kMcgModeBLPE;

The clock manager is such a large chunk of code that I'm planning to ditch it as soon as I have time, so I'm not too worried about this but I thought I'd warn anyone else who might come across it.

 

Scott

Outcomes