AnsweredAssumed Answered

PME software in QorIQ SDK v2.0-1703

Question asked by nic nic on Nov 21, 2017
Latest reply on Feb 5, 2018 by Yiping Wang

Hello,

which yocto packages are required to run PME on LS2088ardb?

I am using QorIQ SDK v2.0-1703.

I see that fsl-pme package does not support LS2088 and simple adding LS2088 to compatibility list does not work.

Also in original firmware shipped with this board there is not any tool starting with pme*.

 

root@ls2088ardb:~# dmesg | grep -i "PME"
[    1.782652] pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot
[    1.783583] pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
[    1.889412] pcieport 0000:00:00.0: Signaling PME through PCIe PME interrupt
[    1.896415] pci 0000:01:00.0: Signaling PME through PCIe PME interrupt
[    1.902981] pcie_pme 0000:00:00.0:pcie01: service driver pcie_pme loaded
[    1.903059] layerscape-pcie 3600000.pcie: failed to get PME IRQ: -6
[    1.909357] layerscape-pcie 3600000.pcie: failed to initialize PME
[    1.963337] pci 0001:00:00.0: PME# supported from D0 D1 D2 D3hot
[    1.984208] pcieport 0001:00:00.0: Signaling PME through PCIe PME interrupt
[    1.991212] pcie_pme 0001:00:00.0:pcie01: service driver pcie_pme loaded
[    1.991279] layerscape-pcie 3700000.pcie: failed to get PME IRQ: -6
[    1.997576] layerscape-pcie 3700000.pcie: failed to initialize PME

 

Is PME supported in this processor?

Outcomes