AnsweredAssumed Answered

LPC Link 2 Dual Debug Configurations

Question asked by jschepler on Nov 16, 2017
Latest reply on Nov 17, 2017 by jschepler

Hello,

 

I am using MCUXpresso IDE v10.0.2 with a Kinetis K64F processor.  I have ported over the KSDK 1.3.0 version with MQX as the OS.  We will not be migrating to KSDK 2.X series since MQX is no longer free.

 

I use the MQX TAD views since they are critical for viewing os performance.  The only way this works with the LPCLink2 is if I use it in "all-stop" mode.  However, we also like the "non-stop" feature of the LPCLink2 which is being able to view variables each second without having to pause program execution.

 

I would like to create 2 debug configurations for the LPCLink2: 1 in Non-Stop Mode, and 1 in All-Stop Mode.  

 

Here is my procedure for creating these configurations.

 

  1. Remove all LPC Link 2 configurations from the project.
  2. Click the "Blue Bug" icon to automatically search for probes.
  3. From the "Probes Discovered" dialog, choose IDE Debug Mode --> All-Stop.
    • LPC Link 2 Probes Discovered Dialog
  4. Click Ok.
  5. The debug session starts and all is well.
  6. Stop debugging and go to LPCLink2 debug configurations.
  7. Right-click on the configuration created automatically and select "Duplicate"
  8. On the duplicated configuration go to the Debugger Tab, Main, and check "Non-Stop Mode"
  9. Click Apply.
  10. Click Debug.
  11. The debug session will start and break at main like usual.  However, when I press play I no longer have the "Pause" option available, it is grayed out.  
  12. It does stop at breakpoints and I am able to step when it breaks, but I don't have the option to pause.  Also, when I press the red "Terminate" button it does not actually disconnect from the target.  In task manager arm-non-eabi-gdb.exe is still running.  I have to restart MCUXpresso after killing the arm-none-eabi-gdb task to be able to debug again, or it says a session is already deployed.

 

Is there something else that needs to be changed when I copy over the configuration? 

 

Once I have an LPCLink2 configuration and I press the blue debug icon it automatically launches the one I created instead of pulling up the probe discovery dialog.

Outcomes