AnsweredAssumed Answered

IVOR 1 when writing to LINFlex DMATXE

Question asked by Cecilia C on Nov 8, 2017
Latest reply on Nov 10, 2017 by James Murray

Hi I am running MPC5746R and have the following code to configure UART on LINFlex_3

 

/* enter INIT mode */
LINFlexD_3.LINCR1.R = 0x0081; /* SLEEP=0, INIT=1 */

/* wait for the INIT mode */
while (0x1000 != (LINFlexD_3.LINSR.R & 0xF000)) {}

/* configure for UART mode */
LINFlexD_3.UARTCR.R = 0x0001; /* set the UART bit first to be able to write the other bits */

LINFlexD_3.UARTCR.R = 0x0033 | 1 << 8 | 1 << 9;
/* Transmit buffer size = 1 (TDFL = 0 */
/* Receive buffer size = 1 (RDFL = 0) */


LINFlexD_3.DMATXE.R = 0x00000001; //enable DMA
LINFlexD_3.DMARXE.R = 0x00000001; //enable DMA

//115200kb with 100 MHz
LINFlexD_3.LINFBRR.R = 4;
LINFlexD_3.LINIBRR.R = 54;

/* enter NORMAL mode */
LINFlexD_3.LINCR1.R = 0x0080; /* INIT=0 */

 

The problem is that I am not able to execute the command that sets the register DMATXE...it results in IVOR 1.

 

However the same code run fine when using LINFlex_0, is there any special setting to make it work on the other LINFlex modules??

 

Thanks,

Cecilia

Outcomes