AnsweredAssumed Answered

Wake on lan in imx6 sabresd board

Question asked by Wang victor on Nov 8, 2017
Latest reply on Nov 8, 2017 by Wang victor

Hi All,

I've install ethtool and etherwake on my computer with Ubuntu 16.04 as OS system.

And I've checked what wake-on does it support from my computer.

Bellow is the result.

root@arm:~# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
...
....
Supports Wake-on: g
Wake-on: d
Link detected: yes

It can only support for g(magic package active).

But when I man ethtool, it show as bellow.

p|u|m|b|a|g|s|d...
Sets Wake-on-LAN options. Not all devices support this. The argument to this option is a string of characters specifying which options to enable.

p Wake on PHY activity
u Wake on unicast messages
m Wake on multicast messages
b Wake on broadcast messages
a Wake on ARP
g Wake on MagicPacket™
s Enable SecureOn™ password for MagicPacket™
d Disable (wake on nothing). This option clears all previous options.

And for my other computer which is X86 for the CPU and with ubuntu16.04 can suport "pumbg".

My question is that CPU(iMX6 sabresd) cannot support all the function or I need to modify the config or the kernel even the boot environment?

 

Thanks in advanced.

Outcomes