AnsweredAssumed Answered

Kernel panic issue and Weston launching issue with yocto morty build for imx6qp sabre AI board

Question asked by lavakumar s on Oct 30, 2017
Latest reply on Nov 7, 2017 by lavakumar s

hi,

 

I am working on imx6qp sabre auto board, (MCIMXABASEV1,MCIMX6QPAICPU3 cards).

building Linux ivi-image with yocto platform. it was working fine with Jethro realease.

 

but I wanted to move the Weston to latest version i.e Weston_1.11.0 build successful(except for Weston_1.13.0) but Weston was launching on target . so decided to move the yocto version to morty.

 

now yocto morty (repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-morty)

tried building image using : bitbake fsl-qt5-image -k.

 

here Linux-imx_4.9.11 as well as Linux-imx_4.1.15 not working ("fetcher failure errors")

so used Linux-imx_4.1.15.bb from jethro yocto build file .

kernel boot stops after "starting kernel " print.

is that correct?? let me know what to do? but still kernel not booting so copied kernel image from jethro build to sd-card and tried to check GUI here Weston not launching. please help here

 

this version has Weston_1.11.0. here also yocto build successful but when I try to launch the Weston I am getting  segmentation fault.  issue is same as with the yocto jethro version.

 

Please help me resolving this issue.

 

Note : please check the attachments.

 

Regards,

Lavakumar S

Attachments

Outcomes