AnsweredAssumed Answered

kinetis design studio headless java error

Question asked by Steve Iribarne on Oct 25, 2017
Latest reply on Oct 26, 2017 by Erich Styger

KDS Details:

 

Kinetis Design Studio

Version: 3.2.0

©Freescale Semiconductor, Inc. 2016. All rights reserved.

Kinetis Design Studio includes features from GNU ARM Eclipse plug-ins http://gnuarmeclipse.livius.net

and from SOMNIUM® Technologies http://www.somniumtech.com

Eclipse Version: Luna SR2 (4.4.2)

SOMNIUM® is a registered trademark of SOMNIUM® Technologies Limited. Freescale and Kinetis are trademarks of Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off.

 

OSX Sierra

 

ksdk 1.2.0 (because we use mqx and need to stick to this version).

 

I have issues running the following command:

/Applications/KDS_v3.app//Contents/eclipse/kinetis-design-studio -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild -importAll /Users/steveiribarne/work/my_proj/external

 

and I get the error as a GIANT Alert Dialog box....

 

Java was started but returned exit code=1

-Dosgi.requiredJavaVersion=1.7

-Xms256m

-Xmx512m

-XX:PermSize=256m

-XX:MaxPermSize=512m

-XstartOnFirstThread

-Dorg.eclipse.swt.internal.carbon.smallFonts

-Djava.class.path=/Applications/KDS_v3.app/Contents/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

-os macosx

-ws cocoa

-arch x86_64

-launcher /Applications/KDS_v3.app/Contents/eclipse/kinetis-design-studio

-name Kinetis Design Studio

--launcher.library /Applications/KDS_v3.app/Contents/eclipse//plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20150204-1316/eclipse_1607.so

-startup /Applications/KDS_v3.app/Contents/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

--launcher.overrideVmargs

-product com.somniumtech.branding.kds.ide

-application org.eclipse.cdt.managedbuilder.core.headlessbuild

-importAll /Users/steveiribarne/work/my_proj/external

-vm /Applications/KDS_v3.app/Contents/eclipse/features/com.somniumtech.jre.macosx.cocoa.x86_64_1.7.0.76/jre/Contents/Home/lib/jli/libjli.dylib

-vmargs

-Dosgi.requiredJavaVersion=1.7

-Xms256m

-Xmx512m

-XX:PermSize=256m

-XX:MaxPermSize=512m

-XstartOnFirstThread

-Dorg.eclipse.swt.internal.carbon.smallFonts

-Djava.class.path=/Applications/KDS_v3.app/Contents/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

I have Java version 1.8.  I've tried 1.7 but I get the same error.

 

In my_proj/external are the ksdk library projects.  On the command line I get 

 

Project: ksdk_mqx_lib already exists in the workspace!

 

I don't know the first thing about how to debug this...

 

Can you shed some light on this for me please?

 

Thank you.

 

-steve

Outcomes