AnsweredAssumed Answered

Port E CAN or GPIO does not appear to be functioning on S32K144EVB-Q100X

Question asked by coderunner50 on Oct 19, 2017

I've tried the FlexCAN examples (CAN & CAN-FD) and cannot see any CAN activity on the CAN bus when trying to send a CAN message. I probed the line (TP21) with an oscilloscope and still do not see any activity.

 

To try and rule out any possibility of the transceiver loading down the CAN TX line the 0 ohm resistor was removed for troubleshooting and I still could not see any can activity on the CAN TX line when sending messages.

 

Finally, I tried setting pins 0 to 7 as GPIO Outputs and toggling them at the same rate as the LEDs in the hello world demo app (attached) and I don't see any activity on the Port E GPIO 0 to 7 pins.

 

Am I missing some register(s) or do I have a defective board? I see that I have board S32K144EVB-Q100X which is now being listed as obsolete and that there is a replacement without the X.

Original Attachment has been moved to: S32DS_Test1.zip

Outcomes