AnsweredAssumed Answered

LS1012a standby mode

Question asked by haff on Oct 18, 2017
Latest reply on Oct 19, 2017 by haff

I am working with the custom ls1012a board. Trying to send device to sleep and wake it up. For now stuck after the first step, it doesn't wake up.

 

Running yocto bsp is based on the RDB board. I have configured needed pin (gpio0 27) as gpio in the RCW and tested it's in/out functions. All is ok. Then I have it registered as gpio-key and as a possible wakeup source within dts:

gpio-keys {
    compatible = "gpio-keys";

    up {
        label = "gpio-wake";
        gpios = <&gpio0 27 GPIO_ACTIVE_HIGH>;
        linux,code = <29>;
        gpio-key,wakeup;
    };
};

But still, when I send board into "mem" sleep (tried "freeze" as well, same thing) I can't wake it up with gpio. As a matter of fact, I can't wake it up with anything else as well. I have tried enabling uart as a wakeup source, same thing.

 

What am I doing wrong? Should this work in the current implementation of the BSP? Would be grateful for any pointers where I can look to debug it.

Outcomes