AnsweredAssumed Answered

Cannot halt processor issue

Question asked by Chuan Tian on Oct 18, 2017
Latest reply on Oct 22, 2017 by jeremyzhou

I flashed my own project to LPC54606BD100 and the MCU went to a weird state. No matter what project I tried to flash after that time, it always shows me the following logs.

 

I tried two boards and on Mac and Ubuntu. The MCUXpresso versions are both mcuxpressoide-10.0.2_411.

 

I guess it might be the problem of my project settings, but I don't know what is wrong. Another question is how can I recover my MCU back to normal. Anyone can help? Thanks a lot.

 

MCUXpresso RedlinkMulti Driver v10.0 (Jun 22 2017 23:34:07 - crt_emu_cm_redlink build 272)
Reconnected to existing redlink server (PID 4294967295)
Connecting to probe 1 core 0 (server PID unknown) gave 'OK'
Probe Firmware: Keil ULINK-ME CMSIS-DAP (Keil Software)
Serial Number:  M0645CGE
VID:PID:  C251:2723
USB Path: /dev/hidraw6
Cannot halt processor
Cannot halt processor
number of h/w breakpoints = 6
number of flash patches   = 2
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 2BA01477. CpuID: 410FC240. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Cannot halt processor
Failed on chip setup: Ep(04). Cannot halt processor.

Outcomes