AnsweredAssumed Answered

[S32DS for Power v1.2] Error loading programming algorithm - load aborted.

Question asked by Tadashi Yamagata on Oct 11, 2017
Latest reply on Oct 15, 2017 by Tadashi Yamagata

Hi

 

I tried using S32DS for Power v1.2 with DEVKIT-MPC5748G.

 

Select "New" - "New S32DS Project from Exsample" from the "File" menu and select "MPC5748G" - "hello" to create a project.
Select "Debug Configurations..." on the "Run" menu, set it appropriately on "Debugger" tab and press "Debug" button.

 

The following information appears in the Console and it can not write to the target.
-----------------------------------------------------------------------
Initializing.
MPC574xC Device detected.
Target has been RESET and is active.
CMD>CM C:\NXP\S32DS_Power_v1.2\eclipse\plugins\com.pemicro.debug.gdbjtag.ppc_1.7.2.201709281658\win32\gdi\P&E\nxp_mpc5748g_1x32x1520k_cflash.pcp

Initializing.
MPC574xC Device detected.
Initialized.

;version 1.05, 06/26/2017, Copyright P&E Microcomputer Systems, www.pemicro.com [5748G_6080k]

;device NXP, MPC5748G, 1x32x1520k, desc=CFlash

;begin_cs device=$00F90000, length=$005F0000, ram=$40000000

Loading programming algorithm ...
Error loading programming algorithm - load aborted.
Error occured during Flash programming.
-----------------------------------------------------------------------

 

I also tried S32DS for Power v1.1 in the same way.
In this version, no error occurred and writing to the target was possible.

 

Please advice on how to write to DEVKIT-MPC5748G with v1.2.

 

Regards,
Tadashi Yamagata

Outcomes