AnsweredAssumed Answered

USB examples on FRDM-K28F not working

Question asked by Markus Arzl on Oct 12, 2017
Latest reply on Oct 20, 2017 by Hui_Ma

Hello,


we are evaluating the FRDM-K28F for a HS USB application. But no matter what I try, I can't get USB working.

 

The blink example works nicely ;-)   When I try any of the other USB examples USB never is recognized. Linux lsusb does not change when I attach the USB cable to the "HS USB" port, the USB attach sound is never played. I especially tried the usb_device_cdc_vcom example. The software on the board seems to run nicely, AppTask is repeated in the main loop.
I understand, that there is at least one jumper, which has to be set right ( J53 open?)

 

I am using SDK_2.2_FRDM-K28F, downloaded recently.

 

I compared usb_device_config with the K64F project and even tried to use this file since it seems to have helped others, but no change.

 

Also I have the impression that USBPHYPLLCLK should be active in the configuration ( MCUXpresso config tools doesn't show it as active, but I didn't check if it was activated by some init in SW, which would make sense. Activating this clock in MCUXpresso doesn't change anything).

 

Does anybody have any clue what is going wrong or what else I can check?
Knowing proven good jumper setting would help too.
Or maybe there is a .bin so I can check if there is something wrong with my hw?

I feel quite a bit stuck at the moment and would appreciate any help a lot !

 

Thanks for your clues 8^)
Mark

Outcomes