AnsweredAssumed Answered

Boot problem with u-boot sdk (imx6qsabresd)

Question asked by Giray Kt on Oct 10, 2017
Latest reply on Oct 10, 2017 by igorpadykov

Hello all.

I am working to build a custom bootloader by using SDK. I have achieved to boot the custom board with only using the "u-boot.imx" inside the sdcard. However, when I try to write the "u-boot.imx" on a partitioned sdcard that includes the image that I built previously, the system uses the bootloader which is included the image itself, not the one that I have created using the SDK.

 

The procedure that I am following:

1.Writing the image on the sdcard using the "$ sudo dd if=<.sdcard image> of=/dev/sdb bs=1M" command.

2.Writing the "u-boot.imx" file on the sdcard using the "$ sudo dd if=u-boot.imx of=/dev/sdb1 bs=1M seek=2 conv=fsync"

command. 

        (Additional question: The board does not boot without adding the "seek" part of the command. What is the reason          of this? I will be more than happy, if you answer it.)

        (I try to write the "u-boot.imx" on the first partition of the sdcard to avoid deleting the second partition.)

3.Try to boot it using the board.

4.Board uses the original u-boot (that is included inside the image itself) not the one that I have created using the SDK. I want to boot it with the SDK one.

            (The date of compilation of the u-boot is Oct 03 2017 when I boot the device. I created the SDK one on Oct 09             2017. That is how I am telling it is using the other one. I do not know this is the correct way to tell it.)

 

I tried numerous solutions to solve this issue. However, none of them worked.

 

Many thanks.

Outcomes