AnsweredAssumed Answered

Unable to get the RappID BL tool to download application+Bootloader

Question asked by Raghu Rajappa on Sep 25, 2017
Latest reply on Oct 20, 2017 by dumitru-daniel.popa

Problem - 

Unable to use RappID BL to download the program to the microcontroller after generating code successfully using Simulink. Screenshot attached below. 

 

Hardware - 

I am using XPC56XX EVB motherboard (Rev.B) + SPC56EL 144 pin ADPT board (yes it's a mini module from ST microelectronics) + MPC5643L (144pin). 

The code is to be programmed using CAN. So I am using a CANcaseXL (Vector) and CAN cable (with 120ohm terminator at the target side). This hardware is detected correctly and driver is installed correctly. 

The jumper settings - I have tried ABS0=1, FAB=0, ABS2=0 ; ABS0=1, FAB=1, ABS2=0 ; and a few more combinations (ofcourse the combination that the tool also suggests). Attaching an image and also the user manual taken from the RappID BL tool itself. 

I would like you to please help me confirm these jumper settings? I also understand that MPC5643L has a fixed baud rate. So from my understanding, the combination should be ABS0=1, FAB=0, ABS2=0. 

 

I am using CAN (H) port and have enabled this using the jumper settings from the XPC56XX EVB document - Attaching a screenshot of the jumper settings - J27 is 1+3, 2+4. J28 is enabled. This is something I also would like to confirm. I am not sure if I am missing any other important jumper settings on the board but it looks complete to me. 

 

Software - 

From the Simulink, I am attaching the screenshot of the settings used in the block. Also I am just using the simple CAN example. 

 

I don't know what the problem is but I am getting frustrated with it  I am grateful for any help.  Thank you so much. 

 

P.S - Also I m currently using CodeWarrior compiler trial version (shouldn't matter in theory). And the motherboard+controller is NXP and the mini-module is ST micro's

Outcomes