AnsweredAssumed Answered

Write dcd failed / ROM Write failed, addr: 0x020c406c

Question asked by Peter Amond on Sep 11, 2017
Latest reply on Sep 11, 2017 by Yuri Muhin
Branched to a new discussion

Dear All,


This is regarding imax6 processor based custom hardware design.


I tried to run DDR calibration with v.2.7 and v.2.6 but it still get the following error when I click Download on GUI :

"ERROR: Write dcd failed."

But when I comment the following line of the script it run correctly.

//setmem /32 0x020c406c = 0xffffffff

What is the reason for this ?


One of my another custom hardware design which has same design like above I needed to comment following line to load DDR Calibration Script.

//setmem /32 0x020c4080 = 0xffffffff

What is the reason for this random issue ? 



I tried to do this memory calibration using DDR_STRESS_TESTER V1.0.2 as well. Then It occurred following problem.


MX6DQ opened.
rom_write: reading HAB ack failed 0x00000000
ROM Write failed, addr: 0x020c406c
Write dcd failed.

Is this related to (HAB) High Assurance Boot component ? Some issue with the processor ? 




setmem /32 0x020c406c = 0xffffffff

setmem /32 0x020c4080 = 0xffffffff


Above values are in valid address range. And some of my boards could run this script without commenting it. Why is that ? Is this some thing related to iMAX6 manufacturing ? Will they do this kind of restrictions for different batch of productions ?