AnsweredAssumed Answered

Hardware timer problems while setting timer through a task using FreeRTOS in i.MX7

Question asked by harish Ganesan on Sep 8, 2017
Latest reply on Nov 14, 2017 by harish Ganesan

I am using RPMsg tool to communicate between the A7 and the M4 cores of  i.MX7 . My objective is to send commands from A7 to M4 via RPMsg , and perform the respective operation by parsing the command . Inorder to acheive that , i am using an task which parses the command and invokes the respective function as a seperate task . For testing i used , led toggle as one of the commands . So when i send blink through RPMsg , a particular GPIO should start to blink . When i tried this with software timer APIs , the expected result was obtained . But when i tried to configure the hardware timer to produce the delay , it gets stuck before setting the Oscillator prescaler setting of the timer . Both A7 and M4 stops responding after this . I used the timer part in the blinking_imx_demo example provided by FreeRTOS . When i create the task in parallel with the base command parser task , it runs properly until linux boots , after which the blinking process gets stuck . I have verified the device tree entries and the timer i used is disabled for linux . 

 

Any more information needed ? How to correct this problem ? 

 

Update : 

While trying out the demo blinking_imx_demo application , the blinking stops/ hangs heavily after the kernel boots up . The device trees have GPT3 and GPT4 disabled . What am i doing wrong or not doing ?

Outcomes