AnsweredAssumed Answered

FlexCAN Driver Issue on iMX28 linux 2.6.35

Question asked by Karthikeyan S on Sep 7, 2017
Latest reply on Sep 15, 2017 by Karthikeyan S

Hi,

    I am using iMX28 EVK board with linux 2.6.35. I am working on CAN driver support. Earlier I was able to see two CAN node using ifconfig -a, but problem was, I could not set the bitrate to 12500, it was showing 

 

root@mx28evk ~$ ip link set can0 type can bitrate 125000
RTNETLINK answers: Operation not supported

 

Then I got patch following from NXP community,

linux-2.6.35_mainline_flexcan.patch

 

I applied the above patch, but Now I am not able the see the CAN node using ifconfig -a

I have attached the logs

 

Can anyone please help me to make FlexCAN driver work, For the last 3 weeks, I was struggling with CAN driver in iMX28 EVK.

 

Thanks,

Karthik

Outcomes