AnsweredAssumed Answered

Android Patch Error: M6.0.1_2.1.0

Question asked by Bhavesh Moradiya on Sep 5, 2017
Latest reply on Sep 5, 2017 by gusarambula

Hi,

 

I am trying to build Android M6 For my i.Mx6qp Sabre SD board. I followed the instruction avail in Android 6 documents (Android User's Guid Rev. M6.0.1_1.0.0, 04/2016).

 

Downloaded release package: android_M6.0.1_2.1.0_source.tar.gz

Getting Android Source code: 

http://storage.googleapis.com/git-repo-downloads/repo

https://android.googlesource.com/platform/menifest/+/refs/heads -b android-6.0.1_r3

git://git.freescale.com/imx/linux-2.6-imx.git kernel_imx

git checkout m6.0.1_2.1.0-ga 

clone git://git.freescale.com/imx/uboot-imx.git uboot-imx

git checkout m6.0.1_2.1.0-ga

 

Patch:

source /opt/android_M6.0.1_2.1.0_source/code/M6.0.1_2.1.0/and_patch.sh

c_patch /opt/android_M6.0.1_2.1.0_source/code/M6.0.1_2.1.0/ imx_M6.0.1_2.1.0

 

After Few checking I got the following Error:

fatal: bad object f7cfc2cca15736862e45ebef54776e0dfdffeb16
Error! Base version commit f7cfc2cca15736862e45ebef54776e0dfdffeb16 doesn't exist in git /home/<user>/myandroid/prebuilts/qemu-kernel. Stop

 

Please Help Me I already Spend Too much time on this to solve this error Even I tried with Different version of source file with M6.0.1_1.0.0. But Same Result.

 

How to Fix This ?

 

Thanks

Outcomes