AnsweredAssumed Answered

issues with ls102xa patch for gpio

Question asked by Scotty Wimberley on Sep 1, 2017
Latest reply on Sep 19, 2017 by Scotty Wimberley

I am porting u-boot from the NXP SDK for the ls1021ATWR to our custom board.

I intend to use the GPIO lines to turn on/off LEDs for diagnostics and use GPIO lines for other various purposes.

I saw a posting and responses from May 18 & 19 regarding the unimplemented GPIO functionality in u-boot for the twr board. A patch was provided to add the functionality.

I tried the patch and it does not work for me. Some of the patches installed, but some did not. Specifically, one for the makefile did not, so I added the one line manually.

When I tried to build u-boot, it failed because it could not find "GPIO_BASE_ADDR"

I did a grep "grep -r GPIO_BASE_ADDR *" from the u-boot git directory. No such constant was found for this architecture.

I also searched for that text in the patch file. It is not there.

Below is the header for the referenced patch file.

 

diff -urN orig/board/freescale/ls1021atwr/ls1021atwr.c new/board/freescale/ls1021atwr/ls1021atwr.c
--- orig/board/freescale/ls1021atwr/ls1021atwr.c    2017-05-19 16:17:59.724741823 +0200
+++ new/board/freescale/ls1021atwr/ls1021atwr.c    2017-05-19 16:48:37.537989631 +0200

 

So, I have a request and a question:

Request: Could you be so kind as to supply a patch for the current revision of the ls1021atwr board which provides GPIO functionality in u-boot please.

Question: Was the patch supplied ever tried as I see no way it could have worked unless it was due to a possible revision difference.

 

Thank you in advance

Outcomes