AnsweredAssumed Answered

mainline u-boot 2017.07 LS1021A-IOT ref board

Question asked by andy rea on Sep 1, 2017

can someone please shed light on getting the LS1021A-IOT TechNexion board to boot U-boot from the SD card - I'll progress to the QSPI next!

 

I've tried playing with a u-boot image from the SDK for the tower board but that doesn't do anything. i've tried using the mainline u-boot which has a default config for that board. I;ve built it using a couple of different cross compilers ( the one in the SDK an another ) but neither produce a bootable image when i dd it onto the SD card.

 

the OOB SD card boots fine and if i steal the first chunk of that can copy it with dd to my SD card then that copy boots fine also.  the booting U-boot throws out

U-Boot 2014.01Layerscape-SDK-V1.3+g50d6848 (Dec 01 2014 - 13:42:50)

CPU:   Freescale LayerScape LS1021E, Version: 1.0, (0x87081110)

at startup. I see nothing from the uboot i build having copied u-boot-with-spl-pbl.bin to the card, offset by the 8 512byte sectors. the start of the file contains the 55aa 55aa signature.

 

is there anything else I have to setup / copy to the SD card to make it boot? I'm new to this processor but not u-boot / kernel building having worked with a custom iMX5 system a few years ago ( granted before FDT etc came along ) so know most of the fundamentals around that but not sure about the PBI / RCW stuff and whether I need to do anything about that.

 

any help would be gratefully appreciated as this is doing my head in now!

 

thanks

 

Andy

Outcomes