AnsweredAssumed Answered

Windows 10 seems to brick FRDM-KL82Z board - how can I recover it?

Question asked by josepgm on Aug 28, 2017
Latest reply on Sep 6, 2017 by martir

Hi,

 

I have a brand new FRDM-KL82Z board to develop an embedded electronics project.

 

One of my co-workers is using another unit of the same board, and he did a demo project in his Windows 7 computer to check that everything is OK. It works perfectly in his computer with both his board and my one, so I tried to open the same project from my computer but I'm not able to flash the program into de MCU, neither by flashing directly nor by debugging.

 

I've read the information in this, this and this link, but I didn't manage to solve the problem. First I explain how the problems occurs and the messages that MCUXpresso is showing. Later I explain what I've tried.

 

- I installed the drivers successfully (that's what the installer says).

- If I plug the board, the yellow LED is permanently ON.

- Every time I try to debug or flash the program, the yellow LED turns OFF, the red one turns ON and this is what I get from the IDE:

 

- I tried to reflash the bootloader copying the "k20dx128_bootloader_0x5000.bin" and the "k20dx128_frdm_kl82z_if_0x5000.bin" files into the virtual bootloader drive that pops up in my computer (one at a time, not both files at the same time). The yellow LED then keeps blinking rapidly but I don't know what it means. According to this file (Section 3, page 8), 2 seconds off + 8 rapid ON/OFF blinks means an error, but I don't get the 2 seconds off, just constant rapid blinking. After a few minutes I unplugged the board and plugged it again to enter normal mode, but the result is exactly the same.

 

After reading the posts I linked previously about OpenSDA and Windows 10, I disabled removable devices from the library search and started the process all over again: reflash bootloader, plug in, try to debug - but I still get the same message. I then tried to do exactly the same in my co-worker's Windows 7 computer, but it doesn't work for him neither.

 

I don't have and external debugger, so I don't know what to do to make it work with Windows 10.

 

Is there any solution to recover my board and make it usable from my Windows 10 computer with the standard USB connection? If not, what should I do - buy an external debugger such as the Segger J-Link?

 

Thank you.

Outcomes