AnsweredAssumed Answered

Error installing LPCXpresso 8.2.2 under Fedora 26

Question asked by Ingmar Delsink on Aug 21, 2017

Hello,
I'm trying to install LPCXpresso 8.2.2 under fedora 26 but I get the following error:

$ No protocol specified
invalid command name "bind"
while executing
"::unknown bind Text <Tab>"
("uplevel" body line 1)
invoked from within
"uplevel 1 $next $args"
(procedure "::obj::Unknown" line 3)
invoked from within
"bind Text <Tab>"
(procedure "::InstallJammer::InitializeGui" line 19)
invoked from within
"::InstallJammer::InitializeGui "
(procedure "::InstallJammer::InitInstall" line 68)
invoked from within
"::InstallJammer::InitInstall"
(file "/installkitvfs/main.tcl" line 39322)

 

I have installed all the listed dependency's in the INSTALL.txt file.

$ sudo dnf install gtk2.i686 glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686 libusb.i686 libXtst.i686 nss.i686 Last metadata expiration check: 0:00:00 ago on Mon 21 Aug 2017 10:40:19 AM CEST. Package gtk2-2.24.31-4.fc26.i686 is already installed, skipping. Package glibc-2.25-8.fc26.i686 is already installed, skipping. Package glibc-devel-2.25-8.fc26.i686 is already installed, skipping. Package libstdc++-7.1.1-3.fc26.i686 is already installed, skipping. Package zlib-devel-1.2.11-2.fc26.i686 is already installed, skipping. Package ncurses-devel-6.0-8.20170212.fc26.i686 is already installed, skipping. Package libX11-devel-1.6.5-2.fc26.i686 is already installed, skipping. Package libXrender-0.9.10-2.fc26.i686 is already installed, skipping. Package libXrandr-1.5.1-2.fc26.i686 is already installed, skipping. Package libusb-1:0.1.5-8.fc26.i686 is already installed, skipping. Package libXtst-1.2.3-2.fc26.i686 is already installed, skipping. Package nss-3.31.0-1.1.fc26.i686 is already installed, skipping. Dependencies resolved. Nothing to do. Complete!

The strace output looks can be viewed via the attachment.

Original Attachment has been moved to: log.txt.zip

Outcomes