AnsweredAssumed Answered

Using CLEV663B Blueboard Rev3 with Raspberry Pi 3 and I2C

Question asked by Florian Jouffreau on Aug 17, 2017

Hi everyone, 

 

For some time now, I'm trying to get the CLEV663B Blueboard Rev3 working with the Raspberry Pi. With no luck, I've tried using SPI and since I will have to use I2C in the end, I'm now trying to communicate via I2C. 

 

The CLEV663B is functionnal using a LPC11U68 and SPI. 

 

For my latest tests, you will find below my configuration : 

 

- NXPNFCRDLIB LINUX SW PACKAGE (v4.040.05.011646_20161115) , sw3693.zip.

   The only file modified in the package is the NxpNfcRdLib/types/ph_NxpBuild_Lpc.h and here the modifications :

 comment line 64 :

//#define NXPBUILD_PH_LPC1769

uncomment line 67 :

#define NXPBUILD_PH_RASPBERRY_PI

comment line 85 and uncomment line 86 :

//#define NXPBUILD_PHBAL_REG_LINUX_USER_SPI

#define NXPBUILD_PHBAL_REG_LINUX_USER_I2C

comment line 96 and uncomment line 97 : 

//#define NXPBUILD_PHHAL_HW_RC523

#define NXPBUILD_PHHAL_HW_RC663

Soldering on the CLEV663B :

 

I have removed R15, R26 and R21 and placed the 0R resistor on R29, R16 and R20 (as instructed in AN11211).

 

Pinout CLEV663B / RPi :

 

Following the file NxpNfcRdLib/intfs/phPlatform_Port_Pi_RC633.h, here how I connect my two devices : 

Pins for 3.3V, 5V and GND are classicaly connected. The USB alim is also connected.

 

Raspberry PI 3CLEV663B REV 3
PIN 3   (GPIO2)SDA
PIN 5   (GPIO3)SCL
PIN 7   (GPIO4)AD0
PIN 11 (GPIO17)AD1
PIN 13 (GPIO27)P2.4
PIN 15 (GPIO22)P2.5
PIN 16 (GPIO23)P3.3
PIN 18 (GPIO24)RST

 

 

First of all, when I use `i2cdetect` on Raspbian to find the slave adress of the blueboard, frames leave the RPi but no answer from the Blueboard. 

 

I deduce from the datasheet that the slave adress should be 0x28 (as configured in the config file). When I run the first example from the lib, I received the following error (continuously looping on it) :

 

Line : 189  Error - (0x010B) has occured : 0xCCEE CC-Component ID, EE-Error code

So according to the ph_Status.h, it's an error from RC communication in BAL Component Code.

 

Is someone have a hint or a solution to that particular issue ? 

 

Thanks a lot in advance, 

 

Florian Jouffreau

Outcomes