AnsweredAssumed Answered

Problem with Freefall Detection

Question asked by João Paulo on Aug 14, 2017
Latest reply on Aug 14, 2017 by Tomas Vaverka

I am not able to use the FXOS8700CQ accelerometer present on the kv31f board.
I would like to use the freefall function and for this I configured the following registers.

Freefall ConfigurationZ < 0,3g using MFF Function 4g, 100 Hz ODR, Normal Mode
Register NameRegister AddrData (R/W)Description
CTRL_REG10x2A0x00 WStandby mode for writable operations
WHO_AM_I0x0DReadCheck device communication (0xC7)
XYZ_DATA_CFG0x0E0x01 WHight-pass filter disabled, +/-0.488mg/LSB
CTRL_REG10x2A0x18 WSet the device in 100 Hz ODR, Standby
A_FFMT_CFG0x150xA0 WLatch enable, Freefall, Z axis
A_FFMT_THS0x170x05 W0,3g threshold
A_FFMT_COUNT0x180x0A WDebounce 100ms
CTRL_REG40x2D0x04 WFF interrupt enable
CTRL_REG50x2E0x04 Winterrupt routed to INT1 pin
CTRL_REG10x2A0x19 WSet the device in 100 Hz ODR, Active Mode

- The communication is working properly because I can read the WHO_AM_I register,

- I've already followed the AN4070 document,

But it's not working, the Freefall interrupt isn't happening,

I've tried to use the 3 axes and then only one but none worked.

Is there any other register that I need to configure?

What else should I do?