AnsweredAssumed Answered

USBDM not recognised

Question asked by Julian Cox on Aug 7, 2017
Latest reply on Aug 10, 2017 by Julian Cox

This is a problem that has been going on for some time, but it is now critical.

I have been re-designing a new processor into  four products  (all with 50% of the code being common)  that would require approximately 50 000 pieces P/A.  I started with a DEMOQE board and then moved to a S08SH4-based target hardware board with a USBDM. Initially the DEMOQE board worked and I completed the preliminary software design. The two USBDMs (one JS16 and one JM60.) the JS16 worked most of the time and the JM worked occasionally. I would typically re-load the drivers 4 or 5 times before anything would work.

In the external devices list the DEMOQE board is recognised as "DEMOQE", the JS16 ise not "seen" and the JM60 is seen as"USBDM,RS08,HCS08,HCS12,DSC,Coldfire BDM"

In Device Managerthe JM60 has two entries under Hardware Debugging Interface as "USBDM BDM Interface (twice)"

The Device Instance paths are USB\VID_16D0&PID_06A5&MI_00\7&1DAE27BD&0&0000 for the first entry and USB\VID_16D0&PID_06A5&MI_01\7&1DAE27BD&0&0001for the second entry. This USBDM works fine with with USBDM 4.12, but not with CodeWarrior. In Debug Settings > Connection Type my choices are -  GDI Generic, P&E HCS08 FCS, or USB Multilink (none of which I have). If I select P&E HCS08 the debug session starts, but the program loops continuously on a single instruction in the initialisation sequence.

With DEMOQE In device manager under "Jungo Connectivity" I get PEMicro USB and Serial Interface (i00) and (i01)

The Device Instance paths are USB\VID_1357&PID_0504&MI_00\6&245CB511&0&0000 for the first entry

and USB\VID_1357&PID_0504&MI_01\6&245CB511&0&0001for the second entry. I also have device "Windriver" with 

Device Instance path ROOT\JUNGO\0000. In C/W when I try to debug  I get a connection error

 

 I have tried two Windows machines, an old windows laptop and two IMACS running Windows 7 virtual machines and I have had the greatest success(???) on the iMACS, I have removed all software drivers and re-installed and updated the drivers, I have re-installed C/W. I have even re-installed Windows on one machine. As of now I have three platforms - one is not seen, one is not recognised and one works with USBDM 4.12, but not C/W.

If I cannot even debug my code I may need to consider another processor. I am just going around and around in circles.

Outcomes