AnsweredAssumed Answered

USB HS not working on TWRK65F180M

Question asked by Joel Sall on Aug 8, 2017
Latest reply on Aug 8, 2017 by Joel Sall

Hi!

 

I have a TWRK65F180M and I'm using Kinetis Design Studio.

Without patching the tower the FS USB is not available.

In my final product I will use HS USB, so FS is not very interesting to me.

The USB CDC example project I've looked at use FS. I try to change this define to use HS instead. It does not work. What am I doing wrong? What am i missing?

I have tried with example projects dev_cdc_vcom_freeros_twrk65f180m & dev_cdc_vcom_bm_twrk65f180m.

 

usb_device_config.h

/*! @brief KHCI instance count */
#define USB_DEVICE_CONFIG_KHCI (0U)  // Originally 1 (KHCI is FS)

/*! @brief EHCI instance count */
#define USB_DEVICE_CONFIG_EHCI (1U)  // Originally 0 (EHCI is HS)

 

It always hangs in fsl_clock.c:

CLOCK_EnableUsbhs0PhyPllClock()

/* Wait for lock. */
while (!(USBPHY->PLL_SIC & USBPHY_PLL_SIC_PLL_LOCK_MASK))
{

    // When using EHCI, I never leave this loop.
}

 

Background:

I am trying to use the MCUXpresso SDK to write a USB HS driver. First I tried to cherry-pick and insert in my existing project. It showed up in Windows Device Manager, ut I could not install the driver. Only get some warning about this *.inf is not compatible with x64.

Instead I tried to install via Device Manager Action->Add Legace Hardware. It seemed to install, but did not work anyways.

So, i took a step back and started to try with TWR...

Outcomes