AnsweredAssumed Answered

mfgtool 启动uboot 后 出现 no device

Question asked by zhilin huang on Jul 31, 2017
Latest reply on Aug 14, 2017 by Rita Wang

你好,nxp 工程师:

 

 

我的板子: imx6dl    

我用的 镜像 是通过下面命令生成的

bitbake fsl-image-mfgtool-initramfs

 

 

 

我现在通过 mfgtool 烧写 出现的问题

在第一阶段(即烧写到 sdram 中 的过程),烧写uboot 启动后出现   就 出现 no  device

 

 

按照正常的流程是kernle 起来后才会出现   no device  connetcted    一瞬间

然后又立马识别。 紧接着烧写第2阶段====== 正常的流程是这个样子的。

 

 

 

我现在的板子的otg  id  是悬空的   不知道是不是有影响。

 

 

 

我的是uboot 就出现了   no  device      然后一直都是 no device     导致 kernel  挂载 不了文件系统;

 

下面是  debug

 

 

IR RC6 protocol handler initialized
IR JVC protocol handler initialized
IR Sony protocol handler initialized
IR SANYO protocol handler initialized
IR Sharp protocol handler initialized
IR MCE Keyboard/mouse protocol handler initialized
IR XMP protocol handler initialized
imx2-wdt 20c0000.wdog: use WDOG_B to reboot.
imx2-wdt 20c0000.wdog: timeout 60 sec (nowayout=0)
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
/soc/aips-bus@02100000/usdhc@02194000: voltage-ranges unspecified
sdhci-esdhc-imx 2194000.usdhc: Got CD GPIO
sdhci-esdhc-imx 2194000.usdhc: Got WP GPIO
sdhci-esdhc-imx 2194000.usdhc: No vmmc regulator found
sdhci-esdhc-imx 2194000.usdhc: No vqmmc regulator found
mmc1: SDHCI controller on 2194000.usdhc [2194000.usdhc] using ADMA
/soc/aips-bus@02100000/usdhc@02198000: voltage-ranges unspecified
sdhci-esdhc-imx 2198000.usdhc: Got CD GPIO
sdhci-esdhc-imx 2198000.usdhc: No vmmc regulator found
sdhci-esdhc-imx 2198000.usdhc: No vqmmc regulator found
mmc2: SDHCI controller on 2198000.usdhc [2198000.usdhc] using ADMA
/soc/aips-bus@02100000/usdhc@0219c000: voltage-ranges unspecified
sdhci-esdhc-imx 219c000.usdhc: No vmmc regulator found
sdhci-esdhc-imx 219c000.usdhc: No vqmmc regulator found
mmc2: host does not support reading read-only switch, assuming write-enable
mmc2: new SDHC card at address 0001
mmc3: SDHCI controller on 219c000.usdhc [219c000.usdhc] using ADMA
mxc_vpu 2040000.vpu_fsl: VPU initialized
mmcblk2: mmc2:0001 SD8GB 7.28 GiB
mmcblk2: p1 p2
mxc_vdoa 21e4000.vdoa: i.MX Video Data Order Adapter(VDOA) driver probed
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
wm8962 0-001a: Failed to read ID register
wm8962: probe of 0-001a failed with error -5
imx-wm8962 sound: failed to find codec platform device
imx-wm8962: probe of sound failed with error -22
NET: Registered protocol family 10
sit: IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
Key type dns_resolver registered
cpu cpu0: failed to get regulators
imx6q-cpufreq: probe of imx6q-cpufreq.0 failed with error -2
Registering SWP/SWPB emulation handler
imx6dl-pinctrl 20e0000.iomuxc: pin MX6DL_PAD_GPIO_1 already requested by 20c0000.wdog; cannot claim for 2184000.usb
imx6dl-pinctrl 20e0000.iomuxc: pin-132 (2184000.usb) status -22
imx6dl-pinctrl 20e0000.iomuxc: could not request pin 132 (MX6DL_PAD_GPIO_1) from group usbotggrp on device 20e0000.iomuxc
imx_usb 2184000.usb: Error applying setting, reverse things back
imx_usb 2184000.usb: Can't register ci_hdrc platform device, err=-517
input: gpio-keys as /devices/soc0/gpio-keys/input/input2
snvs_rtc 20cc000.snvs:snvs-rtc-lp: setting system clock to 1970-01-01 00:00:00 UTC (0)
mipi_dsi_pwr_on: disabling
hdmi-5v-supply: disabling
sensor-supply: disabling
wm8962-supply: disabling
usb_h1_vbus: disabling
ALSA device list:
No soundcards found.
Freeing unused kernel memory: 400K (80922000 - 80986000)
Starting UTP
uuc 0.5 [built Jul 31 2017 00:53:00]
UTP: Waiting for device to appear   // 卡死

Outcomes