AnsweredAssumed Answered

Unknown module(s) in QT: webenginewidgets

Question asked by 才俊欧 on Jul 29, 2017
Latest reply on Aug 3, 2017 by 才俊欧

Hi,

I used the yocto to setup my qt5 cross compile enviroment and I am blocked by the error for webenginewidgets.

I tried to fix it bu failed, I need your help.

 

Please see my steps to find what's wrong and show me the right method.

{

*****************

       1. download the source:

~/gbin/repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-4.1-krogoth
MACHINE=imx6qsabresd DISTRO=fsl-imx-x11 source ./fsl-setup-release.sh -b bld-x11
bitbake  meta-toolchain-qt5  
2. setup the enviroment on my x86 pc:
sh fsl-imx-x11-glibc-x86_64-meta-toolchain-qt5-cortexa9hf-neon-toolchain-4.1.15-2.1.0.sh 
ocean@mhimx6t:~/MHCODE/LinuxClient$ qmake -v
QMake version 3.0
Using Qt version 5.6.2 in /opt/fsl-imx-x11/4.1.15-2.1.0/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib
3. build my qt app
ocean@mhimx6t:~/MHCODE/LinuxClient$ qmake
Cannot read /opt/fsl-imx-x11/4.1.15-2.1.0/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory
Project ERROR: Unknown module(s) in QT: webenginewidgets
4. look at my qt project, I have set the QT option webenginewidgets :
ocean@mhimx6t:~/MHCODE/LinuxClient$ head LinuxClient.pro 
QT       += core gui webenginewidgets multimedia
CONFIG += c++11

      5. tried to fix it, prefered to

[meta-qt5] qtbase: avoid qmake errors due to missing oe-device-extra.prihttps://patchwork.openembedded.org/patch/131347/https://patchwork.openembedded.org/patch/131347/

do_install_append() {
+ # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
+ touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri
+
install -m 0755 ${B}/bin/qmake-target ${D}/${bindir}${QT_DIR_NAME}/qmake

 

vi ~/fsl-arm-yocto-bsp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb
+++

 

6. redo bitbake meta-toolchain-qt5
bitbake meta-toolchain-qt5
WARNING: qt3d-5.6.1+gitAUTOINC+7fab1fa656-r0 do_package_qa: QA Issue: qt3d-plugins rdepends on assimp, but it isn't a build dependency, missing assimp in DEPENDS or PACKAGECONFIG? [build-deps]
NOTE: Tasks Summary: Attempted 4683 tasks of which 4506 didn't need to be rerun and all succeeded.
sh tmp/deploy/sdk/fsl-imx-x11-glibc-x86_64-meta-toolchain-qt5-cortexa9hf-neon-toolchain-4.1.15-2.1.0.sh
7. redo qmake in my qt project, one error fixed but still the second ERROR.
qmake
Project ERROR: Unknown module(s) in QT: webenginewidgets

 

*****************

}

Outcomes