AnsweredAssumed Answered

Flash uboot for T2080RDB-PC

Question asked by MING XIA on Jul 26, 2017
Latest reply on Aug 16, 2017 by Yiping Wang

Hi,

I connected the freescale codewarrior USB TAP on the NXP board(T2080RDB-PC Rev C ) and tried to burn the uboot using flash programmer in order to recover the uboot by following the steps described in the NXP video "How to Set Up CodeWarrior® PA10" (the link to this video is How to Set Up CodeWarrior PA10|NXP ) . clicked the "Debug" button on CodeWarrior IDE 10.5 , then a problem occured shown below:

Error launching T2080SRAMDL2-core00_SRAM_T2080_Download
CCSProtocolPlugin : Failed to reset the target
 [CCS last error: T2080: HRESET occurred during transaction ]

 

I do not know how to deal with it .Another way is to make a bootable SD card for T2080RDB-PC. I have tried to burn the uboot image "u-boot-sdcard-2016.09+fslgit-r0.bin" created by the offical NXP QorIQ SDK 2.0 by using the linux command "dd if=u-boot.imx of=/dev/sdb bs=512 seek=2" in MicroSD card. I changed the SW settings for booting from SD card,  the console showed blank.

 

Can someone help me deal with the "Error launching" and show some advice on how to make a bootable SD card for T2080RDB-PC ??

 

Thanks!

 

 

 

 

 

 

 

Outcomes