AnsweredAssumed Answered

Is there a supported for the SABRE board with kernel 3.14.52 & Qt5.7 or greater?

Question asked by Kengyu Lin on Jul 25, 2017
Latest reply on Aug 4, 2017 by Kengyu Lin

I have an i.MX6DL SABRE board, and I'm trying to get a modern build for it. I'm looking to find a Yocto release, 3.14.52 kernel, Qt5.7.1 or greater.

 

 

I attempted to sync/build this:

 

$ repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.14.52-1.1.0_ga

$ repo sync

$ MACHINE=imx6dlsabresd source fsl-setup-release.sh -b build_qt5 -e fb

$ bitbake -k fsl-image-qt5

 

But it seem that this package only contain Qt5.5

But if I change the /sources/meta-qt5 by command:

$ git clone -b master https://github.com/meta-qt5/meta-qt5.git

 

and then try again

$ MACHINE=imx6dlsabresd source fsl-setup-release.sh -b build_qt5 -e fb

$ bitbake -k fsl-image-qt5

 

It shows that:

 

ERROR: ParseError at /home/scout/freescale-3.14-try2/sources/meta-qt5/classes/qmake5_base.bbclass:48: Could not inherit file classes/remove-libtool.bbclass

 

and then stop

 

Can someone help me?

 

2017/08/04 update: 

If I edit ~/freescale-3.14-try2/sources/meta-qt5/classes/qmake5_base.bbclass file

Ln 50 : -- inherit qmake5_paths remove-libtool

            ++ inherit qmake5_paths

 

It can go through, but still stop at the other qt build task.

Now status : pending, and go through another way. (Try porting to kernel4.1.15 EX: Enable QT developement for i.MX6UL )

Thanks everyone who answer to me, and if anyone still have some answer to share, I would be very grateful.

Outcomes