AnsweredAssumed Answered

The interface firmware FAILED to reset/halt the target MCU on FRDM-K64F.

Question asked by Pablo Rico on Jul 20, 2017
Latest reply on Aug 7, 2017 by Hui_Ma

I'm using a FRDM-K64F and I uploaded the MBED firmware (0226_k20dx128_k64f_0x5000.bin) and then the example helloworld_k64f.bin to the board, but the program never runs and I got a txt file called FAIL and it says "The interface firmware FAILED to reset/halt the target MCU", also the chip heats up. I've tried with other firmwares and I got similar issues, doesn't matter which firmaware I upload, I got the file "FAIL.txt". So I don't know if there's a way to solve this.

 

Also I've tried on the MCUExpresso IDE and I get a similar issue that the IDE cannot establish connection with the board.

 

I tried with the J-Link Comander tool with the command "unlock Kinetis", but I cannot connect with the board and I get the next issue: "Unlocking device... ERROR: Read from DP/AP register failed!". So, If you could help me, I would appreciate it.

 

Regards, Pablo.

Outcomes