AnsweredAssumed Answered

No responce from ipfwd_config

Question asked by Michael Chen on Jul 12, 2017
Latest reply on Jul 19, 2017 by Yiping Wang

hi all,

 

I'm trying to run ipfwd_app on LS1043ARDB, after run ipfwd_app, I try to run ipfwd_config,

There is always no outcome from the ipfwd_config, why was that?

 

root@ls1043ardb:~# ipfwd_app&
[1] 1812
root@ls1043ardb:~# Found /fsl,dpaa/dpa-fman0-oh@2, Tx Channel = 80a, FMAN = 0, Port ID = 1
Found /fsl,dpaa/ethernet@0, Tx Channel = 802, FMAN = 0, Port ID = 1
Found /fsl,dpaa/ethernet@1, Tx Channel = 803, FMAN = 0, Port ID = 2
Found /fsl,dpaa/ethernet@2, Tx Channel = 804, FMAN = 0, Port ID = 3
Found /fsl,dpaa/ethernet@3, Tx Channel = 805, FMAN = 0, Port ID = 4
Found /fsl,dpaa/ethernet@4, Tx Channel = 806, FMAN = 0, Port ID = 5
Found /fsl,dpaa/ethernet@5, Tx Channel = 807, FMAN = 0, Port ID = 6
Found /fsl,dpaa/ethernet@8, Tx Channel = 800, FMAN = 0, Port ID = 9
QMan: Allocated lookup table at 0xffff8e7da010, entry count 32769
Configuring for 1 network interface
Allocated DMA region size 0x1000000
ipfwd_app starting
Message queue to send: /mq_snd_1812
Message queue to receive: /mq_rcv_1812
Configured 10G port @ FMAN:0, MAC:9 as IF_IDX:89
Released 0 bufs to BPID 7
Released 0 bufs to BPID 8
cpu hotplug daemon not running: No such file or directory
Released 4096 bufs to BPID 9
Data stashing: Enabled
Thread uid:0 alive (on cpu 1)


[1]+ Stopped(SIGTTOU) ipfwd_app
root@ls1043ardb:~# ps
PID TTY TIME CMD
1809 ttyS0 00:00:00 sh
1812 ttyS0 00:00:00 ipfwd_app
1816 ttyS0 00:00:00 ps
root@ls1043ardb:~#
root@ls1043ardb:~# ipfwd_config -P 1812 -E -a true
^C
root@ls1043ardb:~# cd /usr/etc
root@ls1043ardb:/usr/etc# fmc -c usdpaa_config_ls1043.xml -p usdpaa_policy_hash_ipv4.xml -a
root@ls1043ardb:/usr/etc# ipfwd_config -P 1812 -E -a true

Outcomes