AnsweredAssumed Answered

EIM on M4, while using Linux on i.MX7D

Question asked by Dominik Steinhauser on Jul 13, 2017
Latest reply on Jul 20, 2017 by Dominik Steinhauser

Hi,

 

I would like to use the EIM on the Cortex-M4 of a i.MX7D to access an FPGA. Deploying my program to M4 using u-boot without starting Linux on the A7 works perfectly fine. I am already able to use EIM for communication when I manually reconfigure  the pins in iomuxc registers to use EIM.

However, when the program is running and I boot Linux on the A7, EIM stops working on the M4 and memory accesses to EIM memory space can take up to five seconds. I already tried to disable EIM on the Linux side changing the device-tree. I also tried to load the program for the M4 directly from Linux considering AN5317, which works fine (if I had a program running on M4 already previously, starting it from u-boot), but as soon as I access EIM memory space, Linux and the M4 freeze.

So, could there still be any conflict with EIM at the M4 running Linux? Can you give me some suggestions how to configure Linux in order to avoid those conflicts or do you have in case some example configuration?

 

Thank you very much for your help!

Outcomes