AnsweredAssumed Answered

How to use mfgtool 2 to boot iMX7dsabresd from NAND

Question asked by Carlos Bejar-Colonia on Jul 7, 2017
Latest reply on Jul 10, 2017 by Yuri Muhin

Dear NXP Community,

 

I have an iMX7dsabresd board and would like to boot it from NAND using MfgTool V2.

I have tried mfgtool2-yocto-mx-sabresd-nand.vbs script provided in MfgTool V2, but failed.

I replaced the “sabreauto” with “sabresd” in the same script and I also rebuild Mfg Tools firmware (fsl-arm-yocto-bsp.git) and updated fsl-image-mfgtool-initramfs-imx7dsabresd.cpio.gz.u-boot in the MfgTool. But still fails

 

These are the last lines from the console output:

 

UTP: received command '$ mount -t debugfs debugfs /sys/kernel/debug'

UTP: executing "mount -t debugfs debugfs /sys/kernel/debug"

UTP: sending Success to kernel for command $ mount -t debugfs debugfs /sys/kernel/debug.

utp_poll: pass returned.

UTP: received command '$ flash_erase /dev/mtd0 0 0'

UTP: executing "flash_erase /dev/mtd0 0 0"

flash_erase: error!: /dev/mtd0

             error 2 (No such file or directory)

UTP: sending Non-success to kernel for command $ flash_erase /dev/mtd0 0 0.

utp_poll: exit with status 65280

 

Is mfgtool2-yocto-mx-sabresd-nand.vbs the right file to flash NAND for iMX7dsabresd board or I need to create my own script?

I checked the iMX Yocto Project Guide, iMX Linux User Guide, MfgTool2 documentation, but was not able to figure out. Has any one tried sucessfully that can share the steps to flash NAND on iMX7?

 

Best Regards,

Carlos

Outcomes