AnsweredAssumed Answered

S12XE BDM Communication Loss

Question asked by Tarcisio Julio de andrade on Jul 4, 2017

Hi. I have a new board which uses MC9S12XEQ512. I can program the board any number of times without any problems. But when I start the code, after some unspecified time, my Multilink Interface seems to lose communication with the MCU, and all variables read "0" (zero). The board keeps running, I can interact with it (external world), but without any debug info.

If I try to HALT, nothing happens (maybe because it's a command), and I can only RESET the board. Then it starts ok, and after some time it all happens again.

It's almost like the MCU is holding the BKGD pin LOW.

I've attached some pictures of oscilloscope probing BKGD pin, and also HIWAVE protocol logs.

 

Some Info:

External Crystal: 4 MHz.

Using PLL on Full Swing Pierce Oscillator Circuit.

PLLCLOCK = 80MHz

BUSCLOCK = 40MHZ

 

Initialization Code:

PLLCTL = 0b11001001;
REFDV = 0x40;
SYNR = 0x49;
POSTDIV = 0;

while (!CRGFLG_LOCK) {
}

CLKSEL = 0b11000000;

 

XCLKS pin has a pull-down at all times.

There is a strong external pull-up on RESET pin (10k to 3V3). I also tried removing it, same outcome.

 

Tried using Multilink Universal Rev.A (flash version 6.15) and Multilink Universal Rev.C. I've already changed cables, power sources and so on, same outcome.

 

Any tips?

 

Thanks in advance.

Original Attachment has been moved to: DUMP_COMM.txt.zip

Attachments

Outcomes