AnsweredAssumed Answered

LTIB installation on Ubuntu 14.04 openssl error

Question asked by Hemant Vasantrao Raut on Jul 4, 2017
Latest reply on Jul 4, 2017 by gusarambula

Hello all, 

I am installing LTIB L2.6.35_1.1.0_130130_source on my Ubuntu 14.04 machine. I have also tried with the 12.04 version. I am having below errors

POD document had syntax errors at /usr/bin/pod2man line 71.
make: *** [install_docs] Error 255

These packages failed to build:
OpenSSL
 

Further digging I came to know that this error is with openssl-1.0.1c version and Perl version 5. I have Perl 5.18.2 installed. Some suggest that is this error occurs while installing the documents/man, I should only install the software and not the documentation. I also tried to change the Makefile in /ltib/rpm/BUILD/openssl-1.0.1c  directory with make install_sw only. But somehow the Makefile gets generated every time I build and but the error continues. 

Need one more suggestion - This may sound dumb question  

We have working Linux build with kernel version 2.6 from past few years. But due to some changes in the eMMC Flash, Unfortunately, we don't have the old build set up with us. We are able to create bootable SD card with old rootfs but with driver errors.we need change few things like kernel argument and drivers.

So should we go with LTIB or Yocto, as many forums favor yocto. But I am not sure about yocto with the older version of the kernel.

 

Any help is appreciated, Please suggest.

 

Best Regards, 

Hemant Raut

Outcomes