AnsweredAssumed Answered

imxg2dcompositor

Question asked by Cristiano Chieppa on Jun 30, 2017
Latest reply on Jul 3, 2017 by Cristiano Chieppa

Dear All, I'm struggling with the gstreamer on a SABRE iMX6 quad core. I have prepare an image with Ubuntu 16 and compiled gstreamer iMX. I would like to use the imxg2dcompositor to gather 4 h264 streams. 

 

The pipeline I have prepared, following some docs on the Network, is the following:

gst-launch-1.0 \
imxg2dcompositor name=c background-color=0xFF \
sink_0::xpos=0 sink_0::ypos=0 sink_0::width=400 sink_0::height=300 \
sink_1::xpos=400 sink_1::ypos=0 sink_1::width=400 sink_1::height=300  \
queue2 ! video/x-raw, width=800, height=600 ! imxipuvideosink \
rtspsrc location=rtsp://<user>:<pwd>@192.168.1.250/h264_2 ! rtph264depay ! h264parse ! imxvpudec ! queue2 ! c.sink_0 \
rtspsrc location=rtsp://<user>:<pwd>@192.168.1.188/h264_2 ! rtph264depay ! h264parse ! imxvpudec ! queue2 ! c.sink_1

I have got to face with the following  problem: the video is black, none of the streams is visible. 

If I convert the pipe on my Ubuntu workstation (with the "normal" compositor, and using avdec_h264) everything works like a charm.

Moreover, if I use the same stream (2 times the H264 from a same camera), it works!

 

I have tried several tests to solve the problem, went to any corner of google, but I haven't found out any interesting answer.

 

Btw, I have also tried the imxipucompositor: same problem.

 

Where I wrong?

 

Thank you for any advise.

Outcomes