AnsweredAssumed Answered

MQX 4.1.1 doesn't run on VF61

Question asked by Julen Arregi on Jun 22, 2017
Latest reply on Nov 13, 2017 by Julen Arregi
Hi everyone,

 

I have been doing some tests to see if I can run a MQX 4.1.1 application on the M4 core and Toradex's Linux BSP v2.5 stable (kernel 4.1.15) on the A5 core on the Vybrid VF61 platform.

 

 1.- I've tried the "Ping-Pong example between Linux and eCos RTOS on Colibri VF61" from toradex developer website, loading the M4 firmware to the DRAM and I can see how mcc communication is running fine. (http://developer.toradex.com/knowledge-base/ping-pong-example-between-linux-and-ecos-rtos-on-colibri-vf61)

 

 2.- I've also tried to run the Hello World example (it comes with MQX 4.1.1) described in this link (http://developer.toradex.com/knowledge-base/mqx-on-the-cortex-m4-of-a-colibri-vf61#Running_MQX). Using DS-5 IDE I've debugged the application but I only get to enable MQX OS. After that, it does not create the task that should write "Hello World" on the UART and it keeps running the idle task. This time I'm loading the application into the SRAM (0x3f000000).

 

 3.- Another trial has been done with the real custom application we developed. This application has been tested and works with a previous Linux BSP v2.3 beta 1 (kernel 3.0.15) and the same MQX 4.1.1 version. Similar to the previous trial, when debugging, I can get to enable MQX OS. But after that, the application gets stuck in a serial port initialization and if I pause the debugging session I can see it jumps to the same idle task as in the 2nd test I've done.

 

All the debug sessions have been done while VF61 is in uboot.
Any clue of what is happening that the MQX OS is not able to create any custom task and run normally?

 

Thanks in advance,

 

Julen

Outcomes