AnsweredAssumed Answered

eMMC burning with MFG Tool

Question asked by Mach Lee on Jun 21, 2017
Latest reply on Jun 21, 2017 by igorpadykov

Hi,

My board is MX6Q with eMMC boot configured and NOT EVM available in the market.

I have some problem of burning eMMC with MFG Tool (L4.1.15_2.0.0-ga_mfg-tools)

If I save the cfg.ini like below...

[profiles]
chip = Linux

[platform]
board = SabreSD

[LIST]
name = eMMC

[variable]
board =
plus

then the MfgTool.log is

DLL version: 2.7.0
Wednesday, June 21, 2017 19:52:31 Start new logging
ModuleID[2] LevelID[1]: Boot command-- file I:\Freescale\MFG_TOOL\L4.1.15_2.0.0-ga_mfg-tools\mfgtools-with-rootfs\mfgtools\Profiles\Linux\OS Firmware\firmware\u-boot-imx6q.imx failed to open.errcode is 2
ModuleID[2] LevelID[1]: Parse ucl script failed, error code: 4

But I try like below.....

[profiles]
chip = Linux

[platform]
board = SabreSD

[LIST]
name = eMMC

[variable]
board = einsys
plus =

then the log is 

DLL version: 2.7.0
Wednesday, June 21, 2017 19:55:16 Start new logging
ModuleID[2] LevelID[1]: Boot command-- file I:\Freescale\MFG_TOOL\L4.1.15_2.0.0-ga_mfg-tools\mfgtools-with-rootfs\mfgtools\Profiles\Linux\OS Firmware\firmware\u-boot-imx6dleinsys_sd.imx failed to open.errcode is 2
ModuleID[2] LevelID[1]: Parse ucl script failed, error code: 4

My question is how MFG tool read the CPU code in wrong.

Can anyone help me, please...?

The ucl2.xml modified part is this

<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx6q%plus%%board%.imx" ifdev="MX6Q">Loading U-boot</CMD>

from

<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx6q%plus%%board%_sd.imx" ifdev="MX6Q">Loading U-boot</CMD>

Outcomes