AnsweredAssumed Answered

IMX7 V4L2 Camera  Error

Question asked by Gopinath Srinivasan on Jun 12, 2017
Latest reply on Jun 21, 2017 by vinod hulagabali

Hi All,

 

I am checking camera streaming in IMX7 using gstreamer commands. I am getting below error when I tried to stream 2304 x 1536 (3.4 MP) resolution. Below is the gstreamer command I have used.  

 

gst-launch-1.0 v4l2src device=/dev/video1 ! "video/x-raw,format=(string)UYVY,width=(int)2304,height=(int)1536" ! videoscale ! imxv4l2sink

 

And I got the below error. 

 

====== IMXV4L2SINK: 4.0.9 build on Jun 30 2016 05:45:07. ======
Setting pipeline to PAUSED ...
display(/dev/fb0) resolution is (1280x720).
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
v4l2sink need allocate 3 buffers.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Internal data flow error.
Additional debug info:
/home/bamboo/build/4.1.X-1.0.0_ga/fsl-imx-x11/temp_build_dir/build_fsl-imx-x11/tmp/work/cortexa7hf-vfp-neon-poky-linux-gnueabi/gstreamer1.0/1.6.0-r0/gstreamer-1.6.0/libs/gst/base/gstbasesrc.c(2943): gst_b:
streaming task paused, reason error (-5)
Execution ended after 0:00:04.280681000
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Total showed frames (0), playing for (0:00:04.281360375), fps (0.000).
Freeing pipeline ...

 

 

 

Whereas the same command works fine for 1080P and 720P resolutions and the camera streaming works fine without any issues. 

 


gst-launch-1.0 v4l2src device=/dev/video1 ! "video/x-raw,format=(string)UYVY,width=(int)1280,height=(int)720" ! videoscale ! imxv4l2sink
gst-launch-1.0 v4l2src device=/dev/video1 ! "video/x-raw,format=(string)UYVY,width=(int)1920,height=(int)1080" ! videoscale ! imxv4l2sink

 

When I  tried with fakesink instead of imxv4l2sink, there will be no issues which means the issue is in the display side especially for 3.4 and 3 mega pixels (2304 x 1536 and 2304 x 1296). I want to test the streaming of this higher resolutions. Can  anyone guide me on solving this error ? Your suggestions are highly appropriated.

 

Thanks,

Gopinath S 

Outcomes