AnsweredAssumed Answered

SC16IS752 TX FIFO not registering data from MCU

Question asked by Albert Chau on Jun 7, 2017
Latest reply on Jun 23, 2017 by David Diaz Marin

Hi,

 

I currently have an interface between my MCU (56F8357) and a SPI-to-UART bridge (SC16IS752) setup. I'm using SPI to send a byte of information from the MCU to the bridge. Here's my problem: when I write a char variable to the Transmit Holding Register (THR) in the bridge, I do not see the TXLVL register updating to show that I've added a byte of information to the transmit FIFO. I can see the byte of information on my oscilloscope as it moves out of the MOSI line between the MCU and bridge so the data is definitely sending - but just not registering into the FIFO for some reason

 

I've tried forcing the RTS to active (and make sure CTS is active high as well) to see if something sends out of the TX line on the SC16IS752 but nothing comes out of it. Here's what I have enabled in my registers:

FCR: TX FIFO reset, RX FIFO reset, FIFO enable

IER: RX data available niterrupt

LCR; divisor latch enable, parity enable, stop bit, word length bit 1 and 0

 

I've also tried my setup with Auto-CTS and Auto RTS on and off in the EFR register but to no avail.

 

Thanks for reading and any help would be greatly appreciated!

Al

Outcomes