AnsweredAssumed Answered

i.MX6qp initramfs bundled

Question asked by George Chiao on Jun 1, 2017
Latest reply on Jun 1, 2017 by igorpadykov

Hi,

 

I have searched a few days with no luck hence hoping someone could help if I post my issue instead.

 

I managed to build a bundled zImage-initramfs-xxx.bin which is just a 'core-image-minimal' for machine 'imx6qpsabresd'.  Note this is a bundled initramfs file which includes both kernel and initramfs.cpio.gz.  A few u-boot files (e.g. 'u-boot-xxx') and device tree files (e.g. xxx.dtb) were also being generated together with the bundled zImage-initramfs-xxxx.bin.

 

The frustrating bit is I have a imx6qp Sabre board right in front of me and I wasn't able to boot from the zImage-initramfs-xxx.bin.  BTW I did manage to flash the SD card with the '*.sdcard' image built previously and it worked fine but that has 'rootfs'.  I also tried to flash 'u-boot', 'device tree', 'zImage' and 'rootfs' to the SD card accordingly, and it worked as well; and I thought I could just flash 'zImage-initramfs-xxx.bin' instead of 'zImage' and 'rootfs' it should work but it didn't.   Messages below are from the console-

 

'switch to partitions #0. OK'

'mmc1 is current device'

'Unrecognized filesystem type'

...

'Bad Linux ARM zImage magic!'

 

Someone suggested me 'mfgtools v2' but unfortunately I hit a different issue, as for some reason my Win 7 had never shown the device as 'HID-Compliant Device', instead it was seen as 'USB Serial Port', which resulted in 'Unassigned' and 'No Device Connected' (see attached).

 

Any idea?  is it something to do with the u-boot file which I used is not for the bundled 'zImage-initramfs-xxx.bin'? or something I've done completely wrong?

 

Many thanks in advanced.

Attachments

Outcomes