AnsweredAssumed Answered

some problems with SJA1105

Question asked by Patrick Jakob on May 31, 2017
Latest reply on Apr 26, 2018 by 晓龙 高

Dear Support Team,

 

i have purchased a Eval Board with the NXP chip SJA1105 (OM14510-SJA1105TJP). I have different documentations about the chip. sja1005.pdf, ah1601.pdf, ah1508.pdf and um10851.pdf.

 

I installed the software and run different bash scripts like id.bat. It worked fine. After that i tried to create a configuration. I chose a example configuration and create it with the bash script, after that i exported the hex file to a c file, where i can see the spi messages which i should have to send.

 

My first question is, is there a manual where i can understand how to interpret these c file?

Yes in the documentation above there is the syntax of the messages and some of the data are reasonable but others not. For Example the generic loader format is like:

- spi write command (32 Bit)

- device id (32 Bit)

- Block id 

-  blocklength

- CRC

- DATA

....

- n DATA

- CRC

- ....

 

So i tried to interpret these file and i dont understand what happens after the first data. So the first DATA conforms to the register value´s which i find in the related .py file. But what comes after that because the next 32 Bit are not related to the next register. The value for the next register are more than 64 Bytes away. What are doing these bits between?

 

After that i tried to load the hex config file via the Flash Magic tool to the SJA1105 Chip. Before i do that i read the File AH1508.pdf (Chapter 6), to know how to handle the tool. I did everything what i read under Chapter 6. The tool said transfer was finished. After that i tried to read via the bash scripts the Register, to check if the configuration was successful downloaded, but no one of these scripts works, i get every time a syntax error. The error occurs because the script don´t read a correct value of the sja1105 chip. I unplugged the Voltage and restart it but i cant read anything with the bash scripts. Can you explain me why it doesn´t work anymore?

 

After these 2 problems i connected the SPI (MISO, MOSI, CS, CLK) from X1100 connector to one of our boards. I wrote a small c program, which reads the device id. I can execute the program from the linux system. It worked fine i read the correct device id. After that i tried to read the register 0x1 to check the configuration flags. It worked fine, but everytime i read this register the Counter (NSLOT) show me different value´s, is it normal?

The value of the "CONFIGS" symbol is set to zero = configuration invalid. After that i copied the configuration values from the converted hex file to write it via SPI. After that i read the register again and see the bits changed, but it doesnt work because the bits say i get CRC check failure in the local CRC. I am not sure why i get these error because i copied SPI message from a configuration example and dont change anything in this file. Thats why i asked above about information how to interpret these file to find the failure.

 

Do you know what i´m doing wrong?

 

Best regards

 

Patrick Jakob

Outcomes