AnsweredAssumed Answered

Vivante galcore module slow load time and NO_DMA_COHERENT

Question asked by Francesco Dolcini on May 31, 2017
Latest reply on Jun 6, 2017 by Bio_TICFSL

Hi all,

I am using Vivante GPU on i.MX 6Q on Linux.

 

As already noticed by others (Imx6QP :Why galcore spend a lot of time loading resources? ) galcore module is too slow to load (>700ms).

This is not compatible with our application and we need a solution to have a faster loading.

 

After some investigation we found that setting NO_DMA_COHERENT config option is improving the situation a lot. We have not seen any evident problem doing this (just guessing ... maybe it is working because there is no IOMMU between GPU and i.MX6 processor?).

 

Any comments?

Any better solution to suggest?

 

Thanks,

Francesco

Outcomes