AnsweredAssumed Answered

build own u-boot SRC_URI fails

Question asked by florian koenig on May 30, 2017
Latest reply on Jun 1, 2017 by florian koenig

hi,

i got a u-boot.tgz package and want to build this package instead of the imx u-boot. I created a own layer and inside this i created meta-my-u-boot/recipes-bsp/u-boot/u-boot-my.bb and put the u-boot.tgz file into meta-my-u-boot/recipes-bsp/u-boot/files/ .

 

Then i put into build/conf/local.conf the line   PREFERRED_PROVIDER_virtual/bootloader = "u-boot-my"  

 

Then i run   bitbake -c cleansstate u-boot-my     and  bitbake u-boot-my    . Both run without errors, but do not build anything ?

 

If i run  bitbake -c devshell u-boot-my   and then in the newly opened shell i type "env|grep CC"  it tells me it uses arm-poky-linux-gnueabi   but in my build/tmp/work/  folder are only  all-poky-linux/ , imx6qsabresd-poky-linux-gnueabi/ , cortexa9hf-neon-mx6qdl-poky-linux-gnueabi/, cortexa9hf-neon-poky-linux-gnueabi/ , x86_64_linux/   and x86_64-nativesdk-pokysdk-linux    ?

 

It seemed to use the wrong compiler ?  Why are not error messages appear when i build it without  -c devshell ?

 

My u-boot-my.bb file content is very simple:

 

FILESEXTRAPATH_prepend := "${THISDIR}/files

 

require recipes-bsp/u-boot/u-boot.inc

PROVIDES += "u-boot"

 

LICENSE...

LIC_FILES_CHK.....

 

SRC_URI = "file://u-boot-my.tgz"

S = "${WORKDIR}/u-boot-my

 

PACKAGE_ARCH = "${MACHINE_ARCH}"

COMPATIBLE_MACHINE = "(mx6|mx7)"

 

 

What do i wrong ? 

 

thanks

Outcomes