AnsweredAssumed Answered

KMS does not detect motor parameters

Question asked by Abdullah Kahraman on May 26, 2017
Latest reply on Jun 21, 2017 by Adam Reynolds

I am using a custom board to interface FRDM-MC-LVMTR (LINIX 45ZWN24-40). Attached are the schematic of this board and PCB view.

 

KMS GUI detects parameters as below:

 

 

Lowering identification currents increase the stator resistance up to 10 ohms.. So, I went over to Advanced Tuning, Manual Motor Setup and copied the values I saw from online training videos which use the same motor:

 

After that, I've tested open-loop control by setting the "startup speed threshold" to a very high value such as 5000. Then, I ran the motor to a target speed using "Run & Stop Motor" in "Speed Control" menu. It seems to be working fine until about 3000 rpm. After 3000rpm, the motor stops turning very sharply. However, inside, it vibrates like it is turning at about 3000 rpm and sounds like that, too. When I command down to about 1000 rpm, it starts turning again after it slows down.

 

I've also tested Torque control after setting the "startup speed threshold" to 400 rpm. Regardless of the "Q-Axis Reference" value, it reports the motor speed at about 2600 rpm. I try to disturb the motor with my hand and it seems like it is doing some torque control. However, there seems to be an issue. If I measure the main supply current with a multimeter, and set the "Q-Axis Reference" to a value, let's say 0.4A, and disturb the motor, it is fine until 0.4A. When I go beyond to a value like 0.6A by forcing the motor harder, the control seems to be lost. When I set  "Q-Axis Reference" to 1A, control doesn't get lost at 0.6A, however at about 1.1A..

 

Closed loop mode works only sometimes with the right bandwidth value and only at about 1750 rpm to 2500 rpm. It is very unstable and I need the motor start up to about 1500 rpm using open-loop.

 

I have tried multiple bandwidth values under "Speed Loop Tuning" menu, that changes some behaviour, however I don't see a stable control.

 

How should I troubleshoot this?

Outcomes