AnsweredAssumed Answered

MQX 4.2 GT202 support patch?

Question asked by Eric Texley on May 26, 2017
Latest reply on Jun 6, 2017 by Daniel Chen

Hello to those concerned,

 

I'm trying to build MQX4.2 with GT202 Atheros support.  I've installed MQX4.2.  I've applied the 4.2.0.2 patch.  I've turned on the BSPCFG_ENABLE_ATHEROS_WIFI as well as BSP_ENET_WIFI_ENABLED.  I've copied the Atheros drivers into the MQX distribution.

 

When I build, I am getting these errors:

 

C:/Freescale/Freescale_MQX_4_2/mqx/source/io/enet/atheros_wifi/custom_src/api_interface/cust_api_wmi_rx.c: In function 'fill_scan_info':
C:/Freescale/Freescale_MQX_4_2/mqx/source/io/enet/atheros_wifi/custom_src/api_interface/cust_api_wmi_rx.c:59:16: error: 'ENET_SCAN_INFO' has no member named 'rsn_cipher'
C:/Freescale/Freescale_MQX_4_2/mqx/source/io/enet/atheros_wifi/custom_src/api_interface/cust_api_wmi_rx.c:63:16: error: 'ENET_SCAN_INFO' has no member named 'rsn_cipher'

Am I missing a support patch for MQX4.2 which is required for the GT202 driver?

Outcomes