AnsweredAssumed Answered

Unable to configure UART2 to work on i.MX6SL

Question asked by Nikola Milenkovic on May 23, 2017
Latest reply on May 29, 2017 by Carlos_Musich

Hi everybody,

 

We are working on a custom board with i.MX6SL Processor.

Unfortunately, we are not able to get UART2 to work. Here is the existing code, that we used on our board:

- Linux release 3.14.28

 

- For pin muxing we used #defines found in imx6sl-pinfunc.h

      MX6SL_PAD_LCD_ENABLE__UART2_RX_DATA     0x210 0x518 0x804 0x4 0x2

      MX6SL_PAD_LCD_HSYNC__UART2_TX_DATA       0x214 0x51c 0x000 0x4 0x0

      MX6SL_PAD_LCD_VSYNC__UART2_RTS_B            0x21c 0x524 0x800 0x4 0x3

      MX6SL_PAD_LCD_RESET__UART2_CTS_B             0x218 0x520 0x000 0x4 0x0

 

- Devicetree relevant configuration:

 

  

     

Serial port /dev/ttymxc1 is detected, but still unable to get any communication to work.

To be sure that UART communication is not happening, we connected oscilloscope to the TX and RX lines, and tried to force communication with microcom or echo to /dev/ttymxc1, but still nothing.

Finally, we even tried removing line fsl,uart-has-rtscts and creating loopback between TX and RX lines, no luck.

We are sure that hardware is ok, since when these pins were configured as GPIO, we were able to toggle them.

 

Currently on the board, we are using UART1 as debug console and UART4 for communication with some other chip successfully.

 

 

Any hint would be appreciated,

Nikola

Outcomes